Citi-Tech South Africa - VoIP - Service Outage – Incident details

VoIP - Service Outage

Resolved
Major outage
Started 9 days agoLasted about 3 hours

Affected

VoIP

Major outage from 11:21 AM to 2:29 PM

Updates
  • Resolved
    Resolved

    The VoIP phone service issue has been fully resolved. All systems are stable and operating normally.

    Thank you for your patience and understanding while we worked to restore service.

  • Monitoring
    Monitoring

    All VoIP phone services are now back online. We are actively monitoring the system to ensure stability and continued uptime.

  • Investigating
    Investigating

    We are currently investigating reports of an outage affecting all VoIP phone services. Our team is working to identify the cause and restore connectivity as soon as possible.