Citi-Tech South Africa - Major Outage – Incident details

Major Outage

Resolved
Major outage
Started 13 days agoLasted about 1 hour

Affected

Wireless

Major outage from 6:06 AM to 6:56 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently investigating an issue where some users are unable to access certain websites. Our technical team is actively working to identify and resolve the root cause.

    We’ll provide further updates as soon as we have more information. Thank you for your patience and understanding.