Citi-Tech South Africa - MLHK Outage – Incident details

MLHK Outage

Resolved
Partial outage 30 %
Started 2 days agoLasted 34 minutes

Affected

Wireless

Partial outage from 2:45 PM to 3:19 PM

Updates
  • Resolved
    Resolved

    Troubleshooting revealed a malfunctioning power component that caused the disruption. A fix was implemented, and the connection was restored.

  • Identified
    Identified

    Technicians have been dispatched to conduct further investigation at the affected site.

    Update to follow at 17:30PM.

  • Investigating
    Investigating

    We are currently investigating an internet disruption affecting customers in Keimoes.