Citi-Tech South Africa - Upington Evotel Fiber Outage – Incident details

Upington Evotel Fiber Outage

Resolved
Major outage
Started 2 months agoLasted about 2 hours

Affected

Fibre

Major outage from 1:29 PM to 3:04 PM

Updates
  • Resolved
    Resolved

    We have received notice from Evotel that all Evotel fiber services in Upington have been fully restored.

    Thank you for your patience, and we apologize for any inconvenience caused during the downtime.

  • Monitoring
    Monitoring

    We have observed that services in Upington on Evotel's fiber have been restored. However, we have not yet received an update from Evotel regarding the outage.

    We will provide further updates as soon as we notice any changes or receive information from Evotel.

  • Identified
    Identified

    Evotel has informed us of a network outage affecting Upington, affected clients will experience no connectivity. Evotel engineers are working on resolving this issue as soon as possible. Please visit https://status.evotel.co.za/ for any updates on their side.