Citi-Tech South Africa - Extension High Site (EXHS) Outage - Upington – Incident details

Extension High Site (EXHS) Outage - Upington

Resolved
Partial outage
Started 2 months agoLasted about 6 hours

Affected

Wireless

Partial outage from 5:12 AM to 11:08 AM

Updates
  • Resolved
    Resolved

    Power has been restored and customers are back online.

    We do apologise for any inconvenience caused.

  • Identified
    Identified

    We have investigated reports of service disruptions affecting wireless clients in Extension, Jooste Eiland, and Paballelo. Our network operations team has identified a power outage in the area as the cause. Efforts are underway to restore power to the site. We will provide further updates as they become available.