Scheduled for May 28, 2025 at 3:00 PM – 3:30 PM
Affects
Wireless
Under maintenance from 3:00 PM to 3:30 PM
Completed
May 28, 2025 at 3:30 PMCompleted
May 28, 2025 at 3:30 PMMaintenance has completed successfully
In progress
May 28, 2025 at 3:00 PMIn progress
May 28, 2025 at 3:00 PMMaintenance is now in progress
Planned
May 28, 2025 at 3:00 PMPlanned
May 28, 2025 at 3:00 PMToday ( 28 May 2025), from 17:00 to 17:30 , we'll be conducting maintenance on one of the access points on the highsite.
During this period, internet services for some customers in Augrabies and parts of Marchand will be limited. We apologize for any inconvenience and assure you we're working to minimize downtime.
Please complete any online tasks or downloads beforehand.
We appreciate your understanding as we strive to improve our services.
Thank you for choosing Citi-Tech.