Citi-Tech South Africa - Internet outage (Wireless) – Incident details
All systems operational
Internet outage (Wireless)
Resolved
Major outage
Started 12 days agoLasted about 5 hours
Affected
Wireless
Major outage from 10:49 AM to 3:53 PM
Updates
Resolved
Resolved
The network has remained stable, and all customers have successfully reconnected.
We apologise for any inconvenience caused during this time and appreciate your patience.
Identified
Identified
We have reported the issue to our upstream provider for further investigation. We have also observed that customers have reconnected, but we will continue to investigate to ensure everything is functioning correctly
Investigating
Investigating
We are currently investigating reports of an outage affecting all Wireless customers in the Upington and Kakamas area.